To the end of the year we release a new version 2.1.0 (Codename Bremen) of our popular command line tool. It’s the second release after the official end-of-life of the official Magento 1 version.

We now support the OpenMage LTS Release and added the last two versions to the installer.

A big update for the CI pieplines was done under the hood by Tom Klingenberg. He migrated all the Travis-CI scripts to Github Actions.

The new CI-Pipeline got a new step to test the tool agains the latest OpenMage version.

Changelog

  • New: Github Actions Workflow for QA (by Tom Klingenberg)
  • New: Detect correct OpenMage version in sys:info command (by Sven Reichel)
  • Add: OpenMage LTS 20.0.3 and 20.0.4 to installer (by Christian Münch)
  • Add: add “no-tablespaces” option (by Tony MageMega)
  • Imp: Update for new standard phpstorm.meta used by the JetBrains/phpstorm-stubs library (by Francesco Boes)
  • : Imp: Remove mcrypt from required PHP extension (by Simon Sprankel)
  • Fix: Typo in help (by Rico Neitzel)
  • Fix: Add scheduled_at to fix issue with Aoe_Scheduler (by Christian Münch)
  • New: Update Dependencies: Symfony, faker, composer, psysh

Have fun and stay safe! Your n98-magerun team.


2 Comments

Pol RAVALITERA · January 21, 2021 at 18:04

“We no support the OpenMage LTS Release”

Huhu, mistyping almost caused me a broken heart

    Christian Münch · February 14, 2021 at 14:25

    Thanks for the hint. Yes, it’s a mistake. We DO support the OpenMage release.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.